Jump to content
Sign in to follow this  
Griff

Nauticam NA-D500 for Nikon D500

Recommended Posts

Nauticam have released the NA-D500 which has a built in TTL optical flash converter.

post-50926-0-55300500-1464056061_thumb.png

Share this post


Link to post
Share on other sites

The standard LED flash trigger that ships in these housings is manual only.

 

An accessory part, #26307, TTL Converter for Nikon (Compatible with NA-D5/D500, Sea & Sea YS-D and Inon Strobes), $430 is available to add TTL functionality with Sea & Sea YS-D1, YS-D2, Inon D-2000, S-2000, Z-240.

 

Future revisions or iterations of that part are planned to support Sea & Sea YS-250, and Ikelite DS-160/DS-161.

 

The TTL Converter supports both optical and electrical triggering. With the currently compatible flashes, we recommend optical triggering for the best performance and accuracy. YS-250 and DS-160 don't have optical/slave TTL functionality, so they'll require electrical triggering.

Share this post


Link to post
Share on other sites

Hi Ryan,
but would it be possible to use the YS 250 optical manual?
Would be good to need no electric sync cord....
Regards,
Wolfgang

Share this post


Link to post
Share on other sites

The currently shipping YS-250 work with the standard manual trigger, fired optically.

 

There were some very early YS-250 strobes that were not compatible optically with our previous LED flash trigger. The updated part in D5 and D500 has more power, but we haven't been able to test those early units unfortunately (because we don't have them any longer). We are hopeful that these recent updates allow all YS-250 to be triggered optically (manual power).

Share this post


Link to post
Share on other sites

When might these housings be available?

Share this post


Link to post
Share on other sites

They are shipping now, but my guess is that dealers are filling preorders placed in January... Shipping forecasts will have to come from individual dealers based on their order queues.

Share this post


Link to post
Share on other sites

Hooray mine is with DHL heading to home sweet home :martini:

Hope to have it on time & weather permitting, to dive it this week-end!

Share this post


Link to post
Share on other sites

hi there,

So my NA-D500 housing has arrived and it's just fantastic! Love the ergonomics and design! And the size as well: it fits in my Manfrotto carry-on roller bag thanks to its reasonable height.
Now it's all ready for Sunday's dive, equipped with Tokina 10-17, vacuum system is green etc. etc...
BUT i couldn't manage to get my Inon Z240 type IV strobes to work with the new manual trigger (i am not talking about the optional TTL one, but about the one which comes baseline with the housing).
My Inons are both properly setup in manual mode, and i am sure they work well since i just need to move the fibre optics from NA-D500 housing to my NA-D300s housing which sits next to it, and they fire just well with the NA-D300s housing.
I have looked through the optical fibre attachment holes on the NA-D500 housing, and i can see a pretty bright light coming out when i pull the trigger... though this light is red.
Could that be the reason why my Inons don't like it?
I'd be grateful for any idea on how to fix this, otherwise i'll be stuck with available light shots this Sunday, but i'll dive next to beautiful gorgonians, it would be a shame... ;)
Of course i've written to my local dealer, a very reactive person which i couldn't thank enough, but i am not sure he'll get my message during the weekend, so if some of you guys have ideas, you're welcome to save my gorgonians dive :)
thanks
Nicolas

 

Share this post


Link to post
Share on other sites

hi there,

So my NA-D500 housing has arrived and it's just fantastic! Love the ergonomics and design! And the size as well: it fits in my Manfrotto carry-on roller bag thanks to its reasonable height.
Now it's all ready for Sunday's dive, equipped with Tokina 10-17, vacuum system is green etc. etc...
BUT i couldn't manage to get my Inon Z240 type IV strobes to work with the new manual trigger (i am not talking about the optional TTL one, but about the one which comes baseline with the housing).
My Inons are both properly setup in manual mode, and i am sure they work well since i just need to move the fibre optics from NA-D500 housing to my NA-D300s housing which sits next to it, and they fire just well with the NA-D300s housing.
I have looked through the optical fibre attachment holes on the NA-D500 housing, and i can see a pretty bright light coming out when i pull the trigger... though this light is red.
Could that be the reason why my Inons don't like it?
I'd be grateful for any idea on how to fix this, otherwise i'll be stuck with available light shots this Sunday, but i'll dive next to beautiful gorgonians, it would be a shame... ;)
Of course i've written to my local dealer, a very reactive person which i couldn't thank enough, but i am not sure he'll get my message during the weekend, so if some of you guys have ideas, you're welcome to save my gorgonians dive :)
thanks
Nicolas

 

I thought it could deserve a dedicated discussion, so new thread open here:

http://wetpixel.com/forums/index.php?showtopic=58037

Share this post


Link to post
Share on other sites
Sign in to follow this  

Sponsors

Advertisements



×
×
  • Create New...