Jump to content
Sign in to follow this  
emilio_goncalvez

Mold inside housing

Recommended Posts

Hello

 

thanks to your forum to exist.

 

I made a big mistake and I left my housing closed for two months or even more (certainly more). I was 500% sure that the housing was open but I was wrong, and the camera was inside as well.

 

Now seems that I do have mold inside as I was not really serious at all about this. How can I clean the housing conscientiously? I'd like to kill all this but I'm worried to damaged the housing OR not kill everything properly.

 

the housing is a fantasea for RX100 IV

 

thanks a lot in advance

 

Share this post


Link to post
Share on other sites

Hi Emilio

 

I’d suggest wiping your house out with a mix of white vinegar and water 1:1. This should remove the mould.

 

Leave it open to dry thoroughly. Retreat if necessary.

Share this post


Link to post
Share on other sites

Hi Emilio

 

I’d suggest wiping your house out with a mix of white vinegar and water 1:1. This should remove the mould.

 

Leave it open to dry thoroughly. Retreat if necessary.

Retreat if necessary? Is that if the mold fights back or multiplies with the application of vinegar and water? :D

Share this post


Link to post
Share on other sites

LOL! Serves me right for trying to respond on an iPhone.

 

Yeah, you have to watch that vinegar.....

Share this post


Link to post
Share on other sites
Sign in to follow this  

Sponsors

Advertisements



×
×
  • Create New...