Jump to content
Alan White

TTL With Aquatica AD800 Housing & Ikelite DS161s & Nikon D800

Recommended Posts

Hi there

I am after some supportive wisdom re. TTL With Aquatica AD800 Housing. I have always had a niggling concern about the TTL strobes (which usually disappears after the first post dive beer is consumed) . Whilst I am getting some pretty good pictures with my rig I don’t feel that the TTL function is woking for the strobes. My kit is:
Nikon D800
Aquatica AD 800 housing (I have all 4 dip-switces set to the ON position)
2 * Ikelite DS161 Strobes
Ikelite 4103.52 cable from housing to strobes (just the cable no additional convertor etc. - though I believe the housing has one in it)
The dip switches in the housing are set to ON position.
Strobes set to TTL
I do nothing specific to the Nikon D800 (just assume it will work TTL mode with the DS161s)
Are there any obvious things for me to check / do to get this working or convince myself that all is well? It may be something to do with camera flat sync settings but that is stretching my knowledge.
Any help gratefully received.
Thanks Alan

Share this post


Link to post
Share on other sites

Hello Alan,

For DS161 strobes TTL control you have to use TTL-Converter for your housing.

For example, UWTechnics internal TTL-Converter #11065, or external Ikelite.

In case of usage #11065, the both strobes will work in TTL.

Edited by Pavel Kolpakov
  • Like 1

Share this post


Link to post
Share on other sites

I had a google around and found two things , first Nikon cameras allow you to attach only one TTL flash of any type to the camera and is likely not to work properly if at all on TTL if you connect two flashes to it. Second the manual mentions there is a model available with ikelite connectors and that this requires the #4301 TTL converter. http://docs.ikelite.com/instructions/4301.3-instructions.pdf The third thing is only one of the connectors will operate in TTL, the other is manual only.

 

Page 10 of the manual I looked at online has all of this info

 

Given that you have Ikelite connectors and flashes I think you need the 4301 TTL converter. The stuff inside the camera is to allow you to configure a direct wired strobe to either TTL or manual and to split off the signal to the secondary strobe to be a manual only strobe and it seems the reason for this is the restriction with Nikon cameras that only allows a single wired TTL strobe to be connected to the camera.

Share this post


Link to post
Share on other sites

Pavel / Chris

 

Thanks very much for your feedback it look as if I have some work to do.

 

Cheers

Share this post


Link to post
Share on other sites

 

Hi there

I am after some supportive wisdom re. TTL With Aquatica AD800 Housing. I have always had a niggling concern about the TTL strobes (which usually disappears after the first post dive beer is consumed) . Whilst I am getting some pretty good pictures with my rig I don’t feel that the TTL function is woking for the strobes. My kit is:
Nikon D800
Aquatica AD 800 housing (I have all 4 dip-switces set to the ON position)
2 * Ikelite DS161 Strobes
Ikelite 4103.52 cable from housing to strobes (just the cable no additional convertor etc. - though I believe the housing has one in it)
The dip switches in the housing are set to ON position.
Strobes set to TTL
I do nothing specific to the Nikon D800 (just assume it will work TTL mode with the DS161s)
Are there any obvious things for me to check / do to get this working or convince myself that all is well? It may be something to do with camera flat sync settings but that is stretching my knowledge.
Any help gratefully received.
Thanks Alan

 

Hi Allan, Are you selling this rig? Thanks! Mark

Share this post


Link to post
Share on other sites

Sponsors

Advertisements



×
×
  • Create New...