Jump to content

- - - - -

Canon 5D Shutter actuation problem with Sea&Sea Housing

Canon 5D Sea and Sea shutter actuation

  • Please log in to reply
1 reply to this topic

#1 Sharksaver



  • Member
  • Pip
  • 18 posts

Posted 27 June 2013 - 01:02 AM

Im in Asia using an older rig since I mostly use video. The canon 5D shoots above water but will not actuate underwater. Ive tried this with 2 lenses. Sometimes it works most times it does not. Ive set the camera to spot focus because the manual focus ring got lost. There is plenty of light and ive tried several exposures and auto. ast option is to set on manual ficus and preset distance. Any suggestions? thank you

#2 errbrr


    Eagle Ray

  • Member
  • PipPipPip
  • 372 posts
  • Gender:Female
  • Location:Melbourne, Australia

Posted 05 July 2013 - 01:16 AM

Try it on manual focus and see if it works...could be that the lens/port combination you have is not the right dimensions to allow the camera to (easily) focus, and it won't shoot until it gets a focus lock.

Also tagged with one or more of these keywords: Canon 5D, Sea and Sea, shutter actuation